re = /^.*(func1)(\()(.{1,64})(,\s*)(.{1,64}[A-Za-z\d])(\))+/
str = 'func2(func1(ef5b, 7dbdd))'
# Print the match result
str.match(re) do |match|
puts match.to_s
end