const regex = /^.*(func1)(\()(.{1,64})(,\s*)(.{1,64}[A-Za-z\d])(\))+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(func1)(\\()(.{1,64})(,\\s*)(.{1,64}[A-Za-z\\d])(\\))+', '')
const str = `func2(func1(ef5b, 7dbdd))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}