import Foundation
let pattern = #"^.*(func1)(\()(.{1,64})(,\s*)(.{1,64}[A-Za-z\d])(\))+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"func2(func1(ef5b, 7dbdd))"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}