using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(func1)(\()(.{1,64})(,\s*)(.{1,64}[A-Za-z\d])(\))+";
string input = @"func2(func1(ef5b, 7dbdd))";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}