$re = '/^.*(func1)(\()(.{1,64})(,\s*)(.{1,64}[A-Za-z\d])(\))+/';
$str = 'func2(func1(ef5b, 7dbdd))';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);