import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\R\\s{5,}";
final String string = "PID: AIR-CAP3502I-T-K9, VID: V01, SN: 0000000000\n"
+ " Inventory for XXXXXXXXXXX\n"
+ "PID: AIR-CAP3502I-T-K9, VID: V01, SN: 0000000000\n"
+ " Inventory for XXXXXXXXXXX\n"
+ "PID: AIR-CAP3502I-T-K9, VID: V01, SN: 0000000000";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}