use strict;
my $str = 'PID: AIR-CAP3502I-T-K9, VID: V01, SN: 0000000000
Inventory for XXXXXXXXXXX
PID: AIR-CAP3502I-T-K9, VID: V01, SN: 0000000000
Inventory for XXXXXXXXXXX
PID: AIR-CAP3502I-T-K9, VID: V01, SN: 0000000000';
my $regex = qr/\R\s{5,}/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";