# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.{3}).*(\..{2,4})/$1...$2/;t' <<< "sssssssssssssssssssssssssssssssssssssssssssss.txt"