$re = '/(.{3}).*(\..{2,4})/';
$str = 'sssssssssssssssssssssssssssssssssssssssssssss.txt';
$subst = "$1...$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;