// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.{3}).*(\..{2,4})").unwrap();
let string = "sssssssssssssssssssssssssssssssssssssssssssss.txt";
let substitution = "$1...$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}