#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.{3}).*(\..{2,4})"
Local $sString = "sssssssssssssssssssssssssssssssssssssssssssss.txt"
Local $sSubst = "$1...$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)