re = /(.{3}).*(\..{2,4})/
str = 'sssssssssssssssssssssssssssssssssssssssssssss.txt'
subst = '$1...$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result