const regex = /(.{3}).*(\..{2,4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{3}).*(\\..{2,4})', '')
const str = `sssssssssssssssssssssssssssssssssssssssssssss.txt`;
const subst = `$1...$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);