#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-z0-9_.%+-]+@[A-z0-9_.%+-]+\.[A-z]{2,4}"
Local $sString = "h@i.com" & @CRLF & _
"hi.chris@gmail.com" & @CRLF & _
"gmail@gmail.com" & @CRLF & _
"test@test.comg" & @CRLF & _
"g@a.c" & @CRLF & _
"ssh username@user"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")