const regex = new RegExp('[A-z0-9_.%+-]+@[A-z0-9_.%+-]+\\.[A-z]{2,4}', 'g')
const str = `h@i.com
hi.chris@gmail.com
gmail@gmail.com
test@test.comg
g@a.c
ssh username@user`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}