use strict;
my $str = 'h@i.com
hi.chris@gmail.com
gmail@gmail.com
test@test.comg
g@a.c
ssh username@user';
my $regex = qr/[A-z0-9_.%+-]+@[A-z0-9_.%+-]+\.[A-z]{2,4}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}