// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-z0-9_.%+-]+@[A-z0-9_.%+-]+\.[A-z]{2,4}").unwrap();
let string = "h@i.com
hi.chris@gmail.com
gmail@gmail.com
test@test.comg
g@a.c
ssh username@user";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}