$re = '/[A-z0-9_.%+-]+@[A-z0-9_.%+-]+\.[A-z]{2,4}/';
$str = 'h@i.com
hi.chris@gmail.com
gmail@gmail.com
test@test.comg
g@a.c
ssh username@user';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);