re = /[A-z0-9_.%+-]+@[A-z0-9_.%+-]+\.[A-z]{2,4}/
str = 'h@i.com
hi.chris@gmail.com
gmail@gmail.com
test@test.comg
g@a.c
ssh username@user'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end