using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(10|11|12|[0]{1}[1-9]{1})\/[0][1-9]|[10-31]?";
string input = @"09/10
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}