$re = '/^(10|11|12|[0]{1}[1-9]{1})\/[0][1-9]|[10-31]?/';
$str = '09/10
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);