package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(10|11|12|[0]{1}[1-9]{1})\/[0][1-9]|[10-31]?`)
var str = `09/10
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}