import re
regex = re.compile(r"^(10|11|12|[0]{1}[1-9]{1})\/[0][1-9]|[10-31]?")
test_str = ("09/10\n\n\n\n\n\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")