import Foundation
let pattern = #"^(10|11|12|[0]{1}[1-9]{1})\/[0][1-9]|[10-31]?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
09/10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}