import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z][a-z0-9_\\.]{5,32}@[a-z0-9]{2,}(?:\\.[a-z0-9]{2,4}){1,2}$";
final String string = "longvu.kiemtien@gmail.com\n"
+ "00tk.quangphuong@gmail.com\n"
+ "nguyentangchien@mail.com\n"
+ "samsam052001@\n"
+ "buithianhthu2612@gmail.com\n"
+ "khanhhn.games@gmail\n"
+ "hienxsktdakla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}