import re
regex = re.compile(r"^[a-z][a-z0-9_\.]{5,32}@[a-z0-9]{2,}(?:\.[a-z0-9]{2,4}){1,2}$", flags=re.MULTILINE)
test_str = ("longvu.kiemtien@gmail.com\n"
"00tk.quangphuong@gmail.com\n"
"nguyentangchien@mail.com\n"
"samsam052001@\n"
"buithianhthu2612@gmail.com\n"
"khanhhn.games@gmail\n"
"hienxsktdakla")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")