$re = '/^[a-z][a-z0-9_\.]{5,32}@[a-z0-9]{2,}(?:\.[a-z0-9]{2,4}){1,2}$/m';
$str = 'longvu.kiemtien@gmail.com
00tk.quangphuong@gmail.com
nguyentangchien@mail.com
samsam052001@
buithianhthu2612@gmail.com
khanhhn.games@gmail
hienxsktdakla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);