#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",(?=(?:[^\]\[]*\[[^\]]*\])*[^\]\[]*$)"
Local $sString = "<[return date("Y-m-d", strtotime("yesterday"));]>,<[return "cool!";]>,TRUE"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)