use strict;
my $str = '<[return date("Y-m-d", strtotime("yesterday"));]>,<[return "cool!";]>,TRUE';
my $regex = qr/,(?=(?:[^\]\[]*\[[^\]]*\])*[^\]\[]*$)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";