import Foundation
let pattern = #",(?=(?:[^\]\[]*\[[^\]]*\])*[^\]\[]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<[return date("Y-m-d", strtotime("yesterday"));]>,<[return "cool!";]>,TRUE"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)