const regex = /,(?=(?:[^\]\[]*\[[^\]]*\])*[^\]\[]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=(?:[^\\]\\[]*\\[[^\\]]*\\])*[^\\]\\[]*$)', 'g')
const str = `<[return date("Y-m-d", strtotime("yesterday"));]>,<[return "cool!";]>,TRUE`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);