using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:[^\]\[]*\[[^\]]*\])*[^\]\[]*$)";
string substitution = @"\n";
string input = @"<[return date(""Y-m-d"", strtotime(""yesterday""));]>,<[return ""cool!"";]>,TRUE";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}