$re = '/,(?=(?:[^\]\[]*\[[^\]]*\])*[^\]\[]*$)/';
$str = '<[return date("Y-m-d", strtotime("yesterday"));]>,<[return "cool!";]>,TRUE';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;