#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)select (.+?)\s+from\s+"
Local $sString = "select a, b, c from a" & @CRLF & _
"" & @CRLF & _
"select * " & @CRLF & _
"from b" & @CRLF & _
"" & @CRLF & _
"select * from a" & @CRLF & _
"where z in (select a.Z from b)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")