re = /select (.+?)\s+from\s+/
str = 'select a, b, c from a
select *
from b
select * from a
where z in (select a.Z from b)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end