package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)select (.+?)\s+from\s+`)
var str = `select a, b, c from a
select *
from b
select * from a
where z in (select a.Z from b)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}