import re
regex = re.compile(r"select (.+?)\s+from\s+", flags=re.DOTALL)
test_str = ("select a, b, c from a\n\n"
"select * \n"
"from b\n\n"
"select * from a\n"
"where z in (select a.Z from b)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")