const regex = /select (.+?)\s+from\s+/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('select (.+?)\\s+from\\s+', 'sg')
const str = `select a, b, c from a
select *
from b
select * from a
where z in (select a.Z from b)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}