using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"select (.+?)\s+from\s+";
string input = @"select a, b, c from a
select *
from b
select * from a
where z in (select a.Z from b)
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}