#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(([+-]*)(\d+)\s*([a-zA-Z]+)\s*)+$"
Local $sString = "1day" & @CRLF & _
"+1day" & @CRLF & _
"-1 day" & @CRLF & _
"+1day-1month" & @CRLF & _
"+1day +1month" & @CRLF & _
" +1day +1month " & @CRLF & _
"###+1day+1month" & @CRLF & _
"+1day###+1month" & @CRLF & _
"+1day+1month###" & @CRLF & _
"###+1day+1month###" & @CRLF & _
"###+1day+1month###"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")