import Foundation
let pattern = #"^\s*(([+-]*)(\d+)\s*([a-zA-Z]+)\s*)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
1day
+1day
-1 day
+1day-1month
+1day +1month
+1day +1month
###+1day+1month
+1day###+1month
+1day+1month###
###+1day+1month###
###+1day+1month###
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}