const regex = /^\s*(([+-]*)(\d+)\s*([a-zA-Z]+)\s*)+$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(([+-]*)(\\d+)\\s*([a-zA-Z]+)\\s*)+$', 'm')
const str = `1day
+1day
-1 day
+1day-1month
+1day +1month
+1day +1month
###+1day+1month
+1day###+1month
+1day+1month###
###+1day+1month###
###+1day+1month###`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}