$re = '/^\s*(([+-]*)(\d+)\s*([a-zA-Z]+)\s*)+$/m';
$str = '1day
+1day
-1 day
+1day-1month
+1day +1month
+1day +1month
###+1day+1month
+1day###+1month
+1day+1month###
###+1day+1month###
###+1day+1month###';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);