import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(([+-]*)(\\d+)\\s*([a-zA-Z]+)\\s*)+$";
final String string = "1day\n"
+ "+1day\n"
+ "-1 day\n"
+ "+1day-1month\n"
+ "+1day +1month\n"
+ " +1day +1month \n"
+ "###+1day+1month\n"
+ "+1day###+1month\n"
+ "+1day+1month###\n"
+ "###+1day+1month###\n"
+ "###+1day+1month###";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}