import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/foo\\/([^\\/]+)$";
final String string = "// Take this string: /foo/bar\n"
+ "// which should be applied to: /foo/?\n"
+ "// where the question mark means required parameter.\n\n"
+ "So the following should be correct:\n"
+ "/foo/bar\n\n"
+ "and the following should be wrong:\n"
+ "/foo\n"
+ "/foo/\n"
+ "/foo/bar/abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}