import re
regex = re.compile(r"^\/foo\/([^\/]+)$", flags=re.MULTILINE)
test_str = ("// Take this string: /foo/bar\n"
"// which should be applied to: /foo/?\n"
"// where the question mark means required parameter.\n\n"
"So the following should be correct:\n"
"/foo/bar\n\n"
"and the following should be wrong:\n"
"/foo\n"
"/foo/\n"
"/foo/bar/abc")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")