# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(?<=itemid=)([0-9]{1,2}).*/_ITEMID_START_\1_ITEMID_END_/gm;t' <<< "itemid=44'>Red Flower</a>"