$re = '/.*(?<=itemid=)([0-9]{1,2}).*/m';
$str = 'itemid=44\'>Red Flower</a>';
$subst = "_ITEMID_START_\1_ITEMID_END_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;