import Foundation
let pattern = #".*(?<=itemid=)([0-9]{1,2}).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"itemid=44'>Red Flower</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_ITEMID_START_\1_ITEMID_END_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)