#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*(?<=itemid=)([0-9]{1,2}).*"
Local $sString = "itemid=44'>Red Flower</a>"
Local $sSubst = "_ITEMID_START_\1_ITEMID_END_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)